Ask a Question

Blocked when changed to production account

hello, I have a developed an application that create a payment order. When using staging host everything is working fine. The same application was working when I switched to satispay production host. However, after some tests, it is not working anymore in may deployed application and I'm able to call it only in my local environment.


We've integrated Satispay in our CRM in order to receive all transactions but there seems to be no way to receive payouts (bank transfers). We ended up simulating a connection to the dashboard by using Puppeteer in headless mode; it had been perfectly working for several months but suddenly a couple of days ago we were no longer able to login, probably due to some new malware/anti spam script implemented on your side. I think that receiving all transactions including payouts is a must have feature for any company; is there a way to accomplish this task?

Include custom headers into redirect_url

Hello, is there a way to let satispay invoking the redirect_url, exposed by my application, including a custom header inside the request? My application requires an api_key inside any received request. When satispay redirects to the endpoint that I’ve included in the body of g_business/v1/payments POST request, the api_key is missing. <br /> I’ve tried to include the custom header api_key inside the g_business/v1/payments POST payment request, but when hitting the redirect_url that is present in the satispay response payload, no custom header is present. Is there a way to include any custom header in the g_business/v1/payments that will be passed to the redirect GET request that will be performed by satispay on payment execution? Regards, Giulio

redirectUrl uuid not replaced within mobile web browser

Ii've created a payment request and when I perform the payment from my phone web browser, the uuid of the payment is not passed into the redirect url but it remains as 3D%7Buuid%7D. Everything is working fine when I invoke the payment request from my pc web browser. After confirming the payment with the app, the redirectUrl is invoked and the uuid is correctly passed in it. How can I have the same behaviour in my mobile web browser? Thanks, Giulio

callback_url of g_business/v1/payments not invoked

after successfully create a payment request through g_business/v1/payments service, the following callback_url is not invoked: http\://localhost:7071/api/callback_url?payment_id={uuid} while redirect url is correctly invoked. Thanks, Giulio

Digest does not match

Ciao, sto utilizzando le API di sandbox per eseguire un pagamento. La create mi funziona e mi restituisce un'id che vado poi a riutilizzare nel Get Payment Details. Quest'ultima però mi da problemi nonostante credo di inserire gli headers corretti (la stessa tripletta date, digest, authorization utilizzata per la create). Sto sbagliando qualcosa? Grazie

Test environment (sandbox) permanently gives 503 server error

Hi, I tried to configure a sandbox account on a PrestaShop ecommerce, successfully registered the activation code and sandbox app but at the moment of showing the QR Code I always receive a 503 server error. Funny thing the payment service seems to work fine in production (QR shows). Is the sandbox environment server running fine?

Ordini immediatamente cancellati

Buongiorno, ho un problema con la ricezione dei pagamenti sul mio e-commerce Woocommerce con Satispay. I clienti effettuano correttamente l'ordine ma questo la maggior parte delle volte viene immediatamente cancellato. Ho letto questa richiesta per lo stesso problema: <https://developers.satispay.com/reference/firewall-configuration> (ho controllato con il mio host e non c'è nessun blocco di sicurezza). Ho letto anche un altra discussione per lo stesso problema: <https://developers.satispay.com/discuss/63f6790b0558f8006de0c895> ed ho provveduto a seguire la guida fornita: Scaricato il plugin: WP-Crontrol Settato come evento: wc_satispay_finalize_orders_event Settato l'aggiornamento a: ogni minuto Vorrei essere certo che questo problema venga risolto, sto perdendo molti ordini. Grazie e buona giornata! <br>

I have an issue testing the Authentication

I get the error Digest doesn't match but it seems that the request is correct: POST /wally-services/protocol/tests/signature HTTP/1.1 content-type: application/json host: staging.authservices.satispay.com date: Mon, 20 Mar 2024 15:10:24 +0000 digest: SHA-256=ZML76UQPYzw5yDTmhySnU1S8nmqGde/jhqOG5rpfVSI= Authorization: Signature keyId="oo75m2ahrt7blqdp8jbo0jdj4gscf38s40f8vd6fct4r0sc6e87ftro2dhojukvufapmspd864begkjg3qp1nmssbquj5n135ohj8letftfnmsqro7kh2786mp8qr025ohvt4v3fm9noaecqkbp4lku6u749bbddo68iucbqbg4n60odqgm64t40cvgkdlpf7dj0fk8j", algorithm="rsa-sha256", headers="(request-target) host date digest", signature="eyOi1sm19p/ZGKE6M02fVGPK8fTWphW+SODxv2GhD9eOZ5IKC42EkI6rS2+KcrE+wGhrF5N3n/aQRc+EtiVer64pWd+i8SnUMWbUhyp4BPKlSq+xOmzqiYvazZrt6haGWYqF+eUc8Y/Z7CNlGUzhcQnQEc951+8EabhRhe87I38hyiWRdkbVAXlwgY19Gxv3HQ87XkuC0SO2zCqovYgh5lQKZdpFGR626vFtwc2PboYZHDezEmVdj6hq53YM4letcVCsUjZI3qmF8Oc/Nkte/Qg/RD7z921bCdE9urnhFSrnhC04kYTKEOXytKfPHD72hZxeuOytfQWKyRP4OP3Iz0UIR6ij/8hsiYvkTGvX56VW+RgDXvjwo6UVKQMs524zcHHpCHYdpqFAKuvLmSsfTjZSOJAgaIGSAUImI4BkWBgXo6NeR2SVkG8HFD0RZxJwuGxlJzq0iiWscpARqjGsKPIe8WwwhZYwIkH5IRc2x5IUi6sHdvFG9CG1WpXB9NdcH360vtVP8H/P/EgaTd9GdOiKO3bgijluq8s5wMauaAad4jQWodyQtBnuO7rMIZr2DlFReton5gA8v0Aci1Iui2G4vwX6F4NmS//rEHPA3fKtCpo4bbRhwbTi5p1g0kg0Zs8CV71hb+7ZAtA/ToZNBWD0V1ykPnPL/IDxQyQ57jg=" User-Agent: PostmanRuntime/7.37.0 Accept: _/_ Cache-Control: no-cache Postman-Token: b524833f-0f5e-4795-bf57-ecb888706d30 Accept-Encoding: gzip, deflate, br Connection: keep-alive { "flow": "MATCH_CODE", "amount_unit": 100, "currency": "EUR" } HTTP/1.1 403 Forbidden Date: Fri, 22 Mar 2024 11:10:22 GMT Server: Apache Content-Type: application/json Content-Length: 61 x-satispay-nch-TVKM: 88YqjqHNVy x-satispay-date: Fri, 22 Mar 2024 11:10:22 GMT Digest: SHA-256=W2mI4ShZqpy8rTaS8mAbFexHGGOa0WXy2F4Kw5uOqxU= x-satispay-cid: Ayk5a7HT Keep-Alive: timeout=5, max=100 Connection: Keep-Alive {"code":52,"message":"Digest doesn't match","wlt":"Ayk5a7HT"}

New activation code

Hello, I lost my keyIds so now I need a new activation code to generate a keyId again. Could you please provide me a new activation code? Thanks